
Google Drawings
Drawings and illustrations are vital to enhance a piece of writing and convey an idea. It is
more effective if it is done perfectly with the help of software applications. Google Drawings
can help you turn ideas into creative sketches by creating shapes and diagrams. It was
launched in 2010 and is available as an application through Chrome OS. Drawings can be
attached to Google documents, presentations, and spreadsheets.

Google Drawings Definition

Google Drawings is a virtual board used to create content by sketching cool images,
creating cute doodles, inserting text, shapes, tables, pasting images, and linking videos and
websites.

What Is Google Drawings?

Google Drawings is a full application software included in the free, web-based Google Docs
Editors offered by Google. Other services include Google Sheets, Google Docs, Google
Slides, Google Forms, and Google Sites. With Google Drawings, users are allowed to
create flow charts, concept maps, diagrams, storyboards, and more. It is also free of charge
to any Google account user. Additionally, its tools are similar to other Google tools. You can
collaborate with others, download an image file, and publish it online.



Google Drawings Benefits

Students

Students will have a convenient way of expressing their creative designs with Google
Drawings’ online tools for their activity or group project in different subject areas. They can
insert image text & insert text, mindmap, beautiful photos with captions, etc.   Aside from
that, it will help hone their creative skills too.

Teachers

With Google Drawings, teachers can effectively illustrate their lessons. The tools are more
straightforward for them to design anything for their class discussions. It is also suitable for
any learning objectives they integrate into their classes.

Professionals

Google Drawings can help any working professional design any graphics for their job. With
the app’s quick and easy tools, they can craft tables, graphs, rotate portraits, and many
other things related to their purpose. Moreover, it can save their time and effort too. Aside
from that. Architects can use it as their sketchbook for 3D drawing where they can create
architecture and interior designs with boxes & corners for dimensions and elevations.

Business

Marketing and monitoring a business are just one of the many advantages of using Google
Drawings. It has the perfect tools and functions to create amusing packaging, branding, etc.
Hiring a graphic designer to design simple layouts is no longer needed, making it more
exciting and valuable.

Google Drawings Templates

You don’t need to start from scratch. Google Drawings provides templates for a diagram.
These are perfect if you plan to craft a grid, hierarchy, timeline, process, relationship, and
cycle. It also comes with different color palettes and layouts that are customizable.
However, if you’re looking for more, you can research available templates online. These
include Venn diagrams, posters, magazines, and many other ready-made templates.



Google Drawings Backgrounds

Google Drawings background has a default size of 960 x 720 pixels (10″ by 7.5″). However,
you can still manage and edit the background size you prefer to use, depending on your
purpose. Just locate the Page Set-up in the File Menu tab to customize it accordingly.
Moreover, you can change your background color to match your layout.

Google Drawings Ideas

Mind Map

Google Drawings is a great way to brainstorm your ideas and transform them into concepts.
With easy peasy tools, you can use the built-in shapes for flowers & flags or scribble tools to
draw your own.

Website Graphics

You can craft any graphics related to your website or blog through image creation tools.
Whether it’s formal or informal, Google Drawings is the best app to use.

Digital Badge

If you’re thinking about making a digital image as an award for reaching a milestone for your
kids, you can start designing a digital badge through Google Drawings’ canvas and tools.

Digital Signature

Google Drawings is not only for designing any illustrations, but you can also use it for
handwriting and saving digital signatures.

Infographics

Google Drawing app is a great tool to represent the data and information you want through
Infographics. It is a natural fit for creating an eye-catching image like a butterfly, nature, and
text for some environmental campaigns and other purposes.



Timeline

You can also utilize the line tools to create any timeline in Google Drawings. Additionally,
you can add text boxes with dates and significant information. Then, add images, videos, or
links to develop interactive timelines.

Logo

Google Drawings is a go-to app for efficient and effective logo creation, whether it’s for a
new business, organization logo, or other purposes.

Postcard

With the helpful tools found in Google Drawings, you can design a postcard of your choice.
You can layout the front and back to make it more appealing in no time.

Vision Board

Through Google Drawings, you can layer images and text to represent your goals with a
vision board. You can have them collaged or arranged accordingly.

Digital Newsletters and Magazines

You can craft and design digital newsletters and magazines anytime. Collaborating with
other writers is also possible since you can have them edited in real-time.

Diagrams & Charts

Google Drawings have prepared templates that are valuable whenever you plan to craft a
network diagram or chart. These are customizable according to your purpose.

Google Drawing vs Jamboard



Google Drawings Alternatives

Lucidchart

Lucidchart is a visual workspace that combines diagramming, collaboration, and data
visualization to accelerate understanding and drive innovation.

Minitab Workspace



Minitab Workspace enables you to move work forward with powerful visual tools, process
maps, brainstorming diagrams, and forms in one intuitive interface right at your fingertips.

Diagrams.net

Diagrams.net (previously draw.io) is a free online diagram drawing application for workflow,
BPM, org charts, UML, ER, and network diagrams.

5 Ways to Use Google Drawings in the Classroom

Graphic Ogranizers

Graphic organizers are now super easy to create. You can create one that works best
across any grade level and discipline for teachers. On the other hand, students can think
visibly about their learning, so you can better yet get them to create!

Interactive Posters

Google Drawings is an excellent spot for creating interactive posters. Regular posters are
static and only contain the information you can fit on them. Interactive posters have
clickable links, making the poster just a starting point for more details.

Comic Strips

You can also create enticing and informative comic strips and digital art without the hassle.
It can be a great way to summarize and tell stories through illustrations and drawings.

Interactive Whiteboard

A blank Google Drawing can turn into an interactive whiteboard that everyone can control.
Any student can insert images & insert text, use dotted lines, and many others by using a
virtual pen and eraser.

Digital Manipulatives



Google Drawings lets you create digital manipulatives like boxes & corners for sticky notes
or cut-out pieces of paper that can move around. Students can also use text boxes, shapes,
or images where they can zoom in & zoom out.

How to Insert a Video in Google Drawings

1. First, create a Google Slideshow.

2. Insert your video onto a slide in the slideshow.

3. If you want to play a portion of the video, set the start and stop time by right-clicking on
the video and choosing “Video options.”

4. Now create (or open) the Google Drawing you want to add the video to.

5. Copy the video from the Google Slideshow.

6. Paste the video on Google Drawing.

How to Use Google Drawings

If you DO NOT have a Google Account

1. Go to www.google.com.

2. Click “Sign In” in the top right-hand corner.

3. Click “Create Account”.

4. Create your account.

If you already HAVE a Google Account

1. Log in to Google.

2. Click on the Google Apps icon.
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3. Click on the drive icon.

4. Click on “New” in the top left corner.

5. Mouse over “More” and select “Google Drawings”.

6. Start creating content!

How to share and export drawings on Google Drawings

1. To export your drawing to your PC, click File and Download and select one of the file
format options.

2. To share your drawing, click the Share button in the top-left, then type in their email
addresses in the People box.

3. To publish your drawing, click File > Publish to the web.

4. Select the size of your published drawing image under the Link tab by selecting a
measure under the Image Size drop-down menu.

5. To embed your published image on the web, click the Embed tab in the Publish to the
web window.

How to Insert Drawing in Google Slides

1. Open Google Slides

2. Click the Insert menu and select the Image button

3. Choose your preferred options in uploading an image

4. Then click the photo that you want to use

How to draw using Google Drawings
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1. To insert an outside image, click Insert>Image and choose one of the available options.

2. To insert text, you’ll need to click the Insert tab and select one of the options.

3. To add a new shape, click Insert > Shape, then choose the type of shape you like.

4. To use line objects to link objects or images together, click Insert>Line and use your
trackpad to create a line object in your chosen location.

5. Click on the gray Untitled drawing box at the top of the Google Drawings window and
type in your preferred name to save your work.

How to create advanced diagrams in Google Drawings

1. Click Insert > Diagrams, then select your diagram style from the menu on the right-hand
side.

2. Click Insert > Table and select the number of columns and rows you need to insert a
table.

3. Click Insert > Charts to do this, then select the type of chart or graph you want to create.

4. Click Insert>Charts then, select the “From Sheets” to insert more graphs from the Google
Sheet.

How to use Mask Tool in Google Drawings

1. Place your image on the canvas.

2. Click the Insert button, then add the Image.

3. Click the crop icon in the toolbar and choose the shape.

4. Your Image will be trimmed to the chosen shape you prefer.
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How to add annotations on screenshot images in Google

Drawings

1. Insert the screenshot by clicking the Insert button then Image.

2. Copy/Paste the image to the Google Drawings’ canvas.

3. Use the tools and arrows in the toolbar to edit the screenshot.

4. Add your preferred annotation conveniently.

How to add Bitmojis in Google Drawings

1. Go to the Chrome Extension toolbar and choose the Bitmoji extension.

2. Find a bitmoji and right-click to copy the image.

3. Right-click to paste the image to the canvas.

4. Customize the bitmoji.

How to insert a photo in the Google Drawings

1. Click the Insert button

2. Click the Image options

3. A dialogue box will appear; click the Search button

4. Type in the image you want to use and click select

How to edit images in Google Drawing

1. To zoom in on the image, click the photo and drag its sides.
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2. To add text, you can click the Insert button then click Text

3. To crop, click the photo, then locate the Crop icon

4. To recolor, locate Image options and click the Recolor button to change

5. To enhance the color, adjust the Transparency, Brightness, and Contrast found in the
Image Options.

How to insert text, change color, font, and size in Google

Drawings

1. Locate the Insert button, then click the Textbox button. Click and drag your mouse to
create a box. Type in the word inside the box.

2. To change the size, highlight text and click the Font size button to choose a size.

3. To change color, highlight text, then click the Text color button to choose a color.

4. To change the font style, highlight text, then click the Font button to choose.

How to insert Word Art in Google Drawings

1. Locate the Insert button, then click the Word Art.

2. Type in the word inside the box on the screen.

3. To change the color inside the letters, click the Fill color button to choose.

4. To change the border color, click the Border color button.

5. To change border weight, click the Border weight button.

6. To change the Font style, click the Font button to choose.
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How to shadow letters in Google Drawings

1. Locate the Insert button, then click. Type in the word inside the box that appears.

2. You can stretch the word according to your desired size.

3. To add a shadow to your letter, you can highlight the word CNTRL+C and CNTRL+V.5.
Click the other copy, then change it to black color.

4. Adjust to make to either way or side you like to make it a shadow letter.

How to shadow images in Google Drawings

1. Locate the Shape button, then click. Select your preferred shape.

2. Locate the Fill color button to choose your desired colors. Click the image, then
CNTRL+C, then CNTRL+V.

3. Change the color and size of the copied image into a darker one.

4. Send the copied image backward by clicking the right-click, then selecting Order options.

5 Customize the shadow image according to your chosen sides or ways.

How to insert an image with a white border drop shadow on

Google Drawings

1. Locate the Insert button and upload your chosen image.

2. Go to the Border Color button and select a white color.

3. Locate the Format options and tick check the Drop Shadow from the options. Click the
Drop Shadow again and adjust

4. You can now change your background to emphasize the drop shadow.

https://www.template.net/google/how-to-shadow-letters-in-google-drawings/
https://www.template.net/google/how-to-shadow-images-in-google-drawings/
https://www.template.net/google/how-to-insert-an-image-with-a-white-border-drop-shadow-on-google-drawings/
https://www.template.net/google/how-to-insert-an-image-with-a-white-border-drop-shadow-on-google-drawings/


How to create a logo with Google Drawing

1. Go to Page set-up and customize your preferred canvas size.

2. Locate Insert and click the Word Art, then type in the word. Change the Font by clicking
the Fonts button to look for more styles.

3. Add shapes by clicking the Shape button to choose.

4. You can add an image by locating the Insert and selecting the Images. Touch up your
design and save.

How to resize the canvas on Google Drawings

1. Go to the File Menu

2. Click Page setup

3. Select your preferred options that appeared.

4. Click the triangle icon on the lower right corner and drag it to your desired size.

How to save a Google Drawing as an Image File

1. Click the File button.

2. Locate Download As and click.

3. Select a PNG image to download the image.

4. Click and drag the downloaded image to your Google Drive.

How to crop images in Google Drawings

1. Locate the Insert button, then click Image options.
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2. Choose your preferred way of downloading an image.

3. Resize the picture to fit on the canvas.

4. Double click on the image.

5. Drag the mouse to your desired size for cropping.

How to crop images into any shapes in Google Drawings

1. Locate the Insert button, then select Image options.

2. Select your preferred way of downloading an image.

3. Fit the image on the canvas accordingly.

4. Double click the image.

5. Locate the Mask Image option from the Crop button.

6. Pick your preferred shape.

How to change the background on Google Drawings

1. Hover your mouse on the blank canvas.

2. Press the right click of your mouse.

3. Select the Background options that appeared.

4. Pick your preferred background color.

How to use the curve tool in Google Drawings

1. Locate the Select Line button and click.
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2. Select the Curve from the options.

3. Start clicking the mouse on the canvas.

4. Continue to click and drag the mouse in your desired direction to create more curves.

How to create a vector drawing with Google Drawings

1. Go to drive.google.com.

2. Create New, then click the More button and select Google Drawings.

3. Locate File Menu, then select Page setup to customize your canvas size.

4. Go to the Tools button, then click Explore

5. Type in the image that you want.

6. Click on the Images options to select your preferred photo and drag them on the canvas.

7. Find the Select Line button and choose Polyline.

8. Create the shapes of the image by clicking and dragging your mouse.

9. Select all the shapes that you have created.

10. Click the line colors and change it.

11. Double click to adjust the vector points.

12. Click on the Select button to delete the unnecessary background and old image.

13. Add borders to enhance your vector image.

How to color with Google Drawings
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1. Upload the image that you want to use.

2. Click on the Select Line options.

3. Choose the scribble button that appeared from the options.

4. Select the Line Color to choose your desired color palette.

5. Select the Line Weight to adjust the thickness of the line.

6. Click on the specific part of the image where you want to put the color.

How to use the scribble tool in Google Drawings

1. Locate the Line button.

2. Click the Select Line options.

3. Choose the Scribble from the drop-down menu.

4. To change color, click the Line Color button.

5. To change the thickness, click the Line Weight button.

6. To change it into the dash, click the Dash Line button.

7. Click on the canvas to form any shapes or scribbled lines.

How to make image reflection in Google Drawings

1. Start by creating a shape of your intended image.

2. Or begin by uploading your chosen image.

2. Click the image, then locate the Format options.
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3. Click the Format options to look for more choices.

4. Tick a check on the Reflection button from the options that appeared.

5. Adjust the Transparency, Distance, and Size of the Reflection according to your desire.

How to Make and Save a Google Drawing

1. Open your Google Chrome and proceed to the Google Apps button to start New.

2. Insert and edit shapes as many as possible that will suffice your drawings.

3. Add text if you want to enhance your drawings with comprehensive details.

4. Save your drawings by downloading them directly to your device.

How to use Google Drawing in Google Classroom

1. Go to Google Chrome and open Google App icons to proceed with Google Drawings.

2. Use the Google Drawings tools to create any graphs, diagrams, and many others for your
lesson and discussion in the Google Classroom.

3. Open Google Classroom and assign the drawings to your students.

4. Share the link to your Google Drawings with your students via email.

How to Embed a Google Drawing into Google Docs

1. Open Google Docs and sign in with your Google Account.

2. Use the different tools in Google Drawings to create your masterpiece.

3. Go to your Document in Google Docs and click Insert to select Drawing, then From Drive.
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4. You can share a link to your Google Drawing file by copying and sending it via email to
link your drawing.

Advantages of Google Drawing

● It is a free drawing app tool
● It can align objects according to your desire
● Many fonts are available for your purpose
● Can overlap and layer objects to create an artwork
● Ability to share and collaborate with other Google users
● Can download your finished project in different formats or insert it into another

Google App
● Users can connect from several different devices and view/edit the drawing in

real-time
● Data is saved on Google’s servers (rather than the user’s hard drive)

Google Drawing Tutorial, Ideas, Tips & Tricks

● Find images with transparent backgrounds
● Customize the size of your Google Drawing
● Add a text box for directions
● Change coloring or transparency of an image


